ES4 Error 10

yagomango
Posts: 3
Joined: Mon Aug 19, 2019 12:09 am

Re: ES4 Error 10

Postby yagomango Mon Aug 19, 2019 10:46 am

I do not know what TeamSpeak or Discord is.
Those are apps that you can use to communicate with others.
Scootboot
Posts: 4
Joined: Thu Jul 25, 2019 2:15 am

Re: ES4 Error 10

Postby Scootboot Mon Aug 19, 2019 6:04 pm

hello, I am having issues flashing the esc.I have tried wiring it up both ways. I am still not having much luck. The issue I am having is "unable to connect with target". coming from the ST Ulitility program.
I get the solid red light and the green light flashes. One long flash then 8 fast flashes.
I'm getting the same issue, hoping it's a PC issue.
Scootboot
Posts: 4
Joined: Thu Jul 25, 2019 2:15 am

Re: ES4 Error 10

Postby Scootboot Mon Aug 19, 2019 6:09 pm

anyone know how to do a chip erase on the control board using stm32?
proplane64
Posts: 5
Joined: Tue Jun 25, 2019 9:37 pm

Re: ES4 Error 10

Postby proplane64 Sat Aug 24, 2019 10:02 pm

anyone know how to do a chip erase on the control board using stm32?
Explanation of diff types of Erase features: https://electronics.stackexchange.com/q ... ctor-erase
How to perform Erase? see http://www.giyf.com
silvera7
Posts: 7
Joined: Sun Aug 25, 2019 6:38 pm

Re: ES4 Error 10

Postby silvera7 Mon Aug 26, 2019 1:42 am

I'd like to add that I have flashed two ESCs with ST-Utility and full dump. The scooter works as intended, however disco lighting has stopped working as mentioned above. The method I used:
Connect ST-Link to ESC
In STUtility press control B and disable readout protection
Open full bin
Press CTRL+P and click program
Go to location 0x1FFFF7E8
Copy first 3 columns of bytes and replace at location 0x0801C1B4

Assemble.
Activate ESC with original ES2/4 serial number

Does everything sound correct here?


EDIT: Turns out it works fine. It seems the lights are faulty on one of mine. I used the ESC on 2 different scooters. Lights work on one, and lights do not work and give a brief error 10 when changing the light colors.
Dude, thank you so much! I followed your instructions and after changing the serial number, all errors are gone and everything works perfectly. Cheers to everyone who helped :D I certainly learned a lot during this process.
Hola !!


quiero activar las luces en un ninebot snsc alguien me puede explicar donde soldar el st-link que pasos seguir? gracias
luarnumber
Posts: 1
Joined: Tue Aug 27, 2019 2:54 am

Re: ES4 Error 10

Postby luarnumber Wed Aug 28, 2019 8:29 am

Hi guys. I have used ST Link and successfully flashed a couple of Dashes and Controller Boards. I've soldered wires directly to the board as well as used a BDM Frame. Now I'm getting "Failed to read memory @ 1FFFFA00!". I have confirmed that my solder joints are good and the wires are in the correct positions. I am using the same method and full dump file but keep getting this error. I even went back to a previous board and tested the ST Link. I thought it was possible the ST Link was bad but it still works fine.

So with this error 10 I can connect with ES Down G but cannot check version so I cannot load the BIN file to flash.

Any suggestions? Thanks in advance.
Yeah I am in the same boat. I have flashed both the dashboard and the controller board and still getting error 10. This is the ES4 with the extra battery and it had the brain at the top I removed.

For the controller, I used a BDM (about $20 from alibaba https://www.aliexpress.com/item/3282232 ... b201603_52)

Followed insructions to flash the dashboard here viewtopic.php?f=6&t=15&start=40
- One thing I encountered is that you really have to scratch the solder on the board quite a bit so your wires can make good contact. Otherwise it'll keep giving errors.
- It's pretty easy to use breadboard wires instead of soldering. https://www.amazon.com/Hyber-Cara-Bread ... s9dHJ1ZQ==. You just connect the ends to the USB ST-LINK and poke the wire through the 3 holes in the dashboard. For that power wire, I just held it in place with clamp. Also this jig seems really useful too https://www.instructables.com/id/Pogo-P ... Connector/

For the controller flashing, Ifollowed diagram on https://imgur.com/a/heG6ETh to connect the USB ST-LINK to the board. 4 wires total. And I used openocd to in MS-DOS command line to run

Code: Select all

"openocd -f interface/stlink-v2.cfg \ -f target/stm32f1x.cfg \ -c "init; reset halt; stm32f1x unlock 0; reset halt; exit"
Followed wielandgeorg's post viewtopic.php?f=6&t=40&start=40 and did the flashing using STM32-LINK app. I think you can do the same using openocd with ("program esc139_fulldump.bin offset 0x8000000"). In STM32-LINK app, I made sure to disable write protection with Control-B and did Unselect All and used Low Power mode. but when I tried to write to address "0x801c1b4", it wouldnt allow me. Something about protection.

Anyways, went ahead and connected everything and device still giving error 10 and there's green on bottom of scooter. Dashboard was a $20 chinese board and control board is original and both I did the flashing.

Anyways...
fivefingerdiscount
Posts: 14
Joined: Sun Jul 28, 2019 2:20 pm

Re: ES4 Error 10

Postby fivefingerdiscount Mon Sep 02, 2019 11:30 pm

So far I flashed one dash and two ESCs and it’s still giving me the same error 10. Anyone know how to erase ESC and start over using STUtility. Or did anyone eles beside that one or two people got this to work? I’m flashing a retired rental
fivefingerdiscount
Posts: 14
Joined: Sun Jul 28, 2019 2:20 pm

Re: ES4 Error 42 -

Postby fivefingerdiscount Wed Sep 04, 2019 4:42 pm

I just wanted to post something I ran into.
I flashed the ESC with the full dump, everything worked fine.

I wanted to changed the dashboard to display mph instead of km so I opened the Ninebot app and connected to my scooter and performed the change.
Everything seemed okay, I then went and flashed a cfw over Bluetooth, everything seemed okay, did a test ride after 20 seconds into the ride the scooter shut off, when I turned it back on I started getting error 42.
Looked up the error code found out it was the external battery, I disconnected it made sure all the screws were tight and reconnected it but kept getting the error 42 - after attempting several things, I decided to take the scooter back apart and re-solder the wires back on to the esc and erase the chip and flash it again.
After putting the scooter back together with the extended battery attached I tested it, all okay again - I been riding it since yesterday few trips been long range, the dashboard is back shown krm. so loaded the ninebot app to change it back to mph.. I disconnected and restarted the scooter, and everything seemed okay...
So today I wanted to test flashing the cfw and see if I get error 42 back, after flashing it I took out to test ride damn it the error 42 started back the very 1st time I touched the break...

So if anyone runs in to the error 42 I would suggest re-flashing your ESC with the full dump again, and delete the NINEBOT app from your phone, so you don't ever connect to your scooter with it. Im pretty sure it's the Ninebot app that triggered the error 42

so now the 3rd time I flashed the ESC but this time don't have the ninebot app, nor am I going to flash cfw to it. If it breaks anytime soon I'll update this posting.
can u tell us which diagram did u used and did you use the old one or bought another one. and which scooter did u used
jacknab
Posts: 8
Joined: Fri May 31, 2019 7:10 am

Re: ES4 Error 10

Postby jacknab Sat Sep 07, 2019 12:21 pm

I do not understand your question?
moiskey
Posts: 3
Joined: Thu Sep 26, 2019 12:54 pm

Re: ES4 Error 10

Postby moiskey Sun Oct 06, 2019 7:32 am

Regards. I have a driver that was misused with an Xiaomi M365 program. how can you recover from scratch please

Image

Return to “Ninebot ES”

Who is online

Users browsing this forum: No registered users and 7 guests