ST-Link BLE110/113 Issues

Posts: 3
Joined: Mon Jun 03, 2019 2:01 pm

ST-Link BLE110/113 Issues

Postby Gaztonz Fri Jan 17, 2020 10:18 pm

As those who have tried know, some(all?) people who have ST-Linked BLE110/113 have issues where the dash is required to "pair" each time you connect to it. Additionally, the dash appears to be read-only as you can't change the name, settings, etc.

Nim on TG posted:
"Ok guys here it is my contribution to the community, unfortunately I was not able to find a solution and I'm done with testing, don't really know how to solve it. For the ones that want to get back from BLE555 to BLE113 or BLE110 and can't do it because of the rom lock,(unable to update and change name) here it's what I did so far.

1) Program via IAP (unable so solve the problem)
2) Program via j-link with segger j-flash, nrf studio or nrf connect (no luck as well)
3) Program using stlink v2 (pro version) same problem.
4) Manipulate some bits in the bin/hex file (no luck)

It's seems to me that it's impossible to fix this, it must be some hardware setting because full erases were done and still no luck. If you want to figure out this here are the steps that don't work so you don't need to repeat them."

I took a look at the full dumps and my findings are:

Scooter name shows as "NBScooter0340" (location 0x3B408 in dump)

Scooter name shows as "N3M-Ninebot-M" (location 0x201E4 and 0x319E4 in dump)

BLE555 has "N3M-Ninebot-M" at location 0x319E4 but nothing in location 0x201E4
BLE110/113 has "NBScooter0340" at location 0x3B408

Each of these versions are pulling the scooter name from different locations. BIN also shows "N3M-Ninebot-Mini0001" at that location, app shows "N3M-Ninebot-M" as the name

Could there be a reason BLE555 is pulling the scooter name from location 0x201E4 and BLE110/113 is pulling the scooter name from locations 0x201E4 or 0x319E4?
Posts: 30
Joined: Mon Feb 24, 2020 4:29 am

Re: ST-Link BLE110/113 Issues

Postby meister_sd Fri Mar 06, 2020 7:04 am

I had some issues too with the BLE. Take a look here for some things that helped me fix mine:


Also, I had to manually rename 0x000201E4 for me to get a custom SSID. The sad part is when I first got the dashboard, I could change all that but after putting BLE555 on, that all was broken.
Posts: 30
Joined: Mon Feb 24, 2020 4:29 am

Re: ST-Link BLE110/113 Issues

Postby meister_sd Mon Apr 06, 2020 6:09 am

I figured out the problem. The script used to program BLE555 is missing a programming command and a file. The script should have more at the end, like the program BLE365REC.

This is the script in the file:
bin\openocd.exe -f share\openocd\scripts\interface\stlink-v2.cfg -f share\openocd\scripts\target\nrf51.cfg -c init -c halt -c "nrf51 mass_erase" -c "program full_BLE.bin"

This is what it should be:
bin\openocd.exe -f share\openocd\scripts\interface\stlink.cfg -f share\openocd\scripts\target\nrf51.cfg -c init -c "reset halt" -c "nrf51 mass_erase" -c "program full_BLE.bin 0 verify" -c "program UICR 0x10001000 verify" -c reset

You need to pull the file "UICR" from ble365rec and put it in the max_BLE555_stlink working directory

Return to “Ninebot KS Max”

Who is online

Users browsing this forum: No registered users and 4 guests